Commit cb7e6617 authored by David Laban's avatar David Laban

depend on gcc@7 explicitly

The latest version of GCC is currently 9, so depending on gcc won't
necessarily give you a binary called /usr/local/opt/gcc@7/bin/gcc-7
parent 5e41bfb5
......@@ -5,7 +5,7 @@ class ArmElfBinutils < Formula
url 'http://ftp.gnu.org/gnu/binutils/binutils-2.27.tar.gz'
sha256 '26253bf0f360ceeba1d9ab6965c57c6a48a01a8343382130d1ed47c468a3094f'
depends_on 'gcc' => :build
depends_on 'gcc@7' => :build
def install
ENV['CC'] = '/usr/local/opt/gcc@7/bin/gcc-7'
ENV['CXX'] = '/usr/local/opt/gcc@7/bin/g++-7'
......
......@@ -5,7 +5,7 @@ class I586ElfBinutils < Formula
url 'http://ftp.gnu.org/gnu/binutils/binutils-2.27.tar.gz'
sha256 '26253bf0f360ceeba1d9ab6965c57c6a48a01a8343382130d1ed47c468a3094f'
depends_on 'gcc' => :build
depends_on 'gcc@7' => :build
def install
ENV['CC'] = '/usr/local/opt/gcc@7/bin/gcc-7'
ENV['CXX'] = '/usr/local/opt/gcc@7/bin/g++-7'
......
......@@ -5,7 +5,7 @@ class X8664ElfBinutils < Formula
url 'http://ftp.gnu.org/gnu/binutils/binutils-2.27.tar.gz'
sha256 '26253bf0f360ceeba1d9ab6965c57c6a48a01a8343382130d1ed47c468a3094f'
depends_on 'gcc' => :build
depends_on 'gcc@7' => :build
def install
ENV['CC'] = '/usr/local/opt/gcc@7/bin/gcc-7'
ENV['CXX'] = '/usr/local/opt/gcc@7/bin/g++-7'
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment