• whitequark's avatar
    Bump Rust version requirement to 1.28. · 7faa206e
    whitequark authored
    Actually, this is not a new requirement at all; because we do not
    check the minimum version on CI, some dependencies on 1.28 have
    already sneaked in. In particular, our required version of the crate
    managed only works on 1.28+.
    
    This allows us to use:
    (1.28)
      - ops::RangeBounds
      - num::NonZero
    
    Some trait bounds were added to make sure everything builds on 1.28.
    7faa206e